広告&webデザイン
お仕事の話

サイトのリニューアルのご依頼をいただいたんだけど、せっかくエキサイトブログで充実した記事を書いておられるので、
それはそのままにして、新サイトにRSSで読み込もうと思いました。

で、

http://kana-lier.com/javascript/google_ajax_rssfeed/

こちらの記事を参考に、html内に記述して、新記事を表示させるところまではうまくいったのですが、
サムネイルの画像がどうしても表示されない!
他サイトなど、めちゃくちゃ調べても分からない・・・。
深夜までがんばってみましたが、もう何がなんだか分からなくなって来たので、こういうときはいったん寝るに限る!と就寝(笑)

一晩経って、「そうだ、他のブログではどうなんだ?」と、自分のアメブロを読み込んでみたらうまくいった。
ここでようやく、エキサイトブログに問題があると気がつく・・・。

で、再度「エキサイトブログ RSS 画像 表示されない」などでググってみると、ヒットしたのが上記のサイトのコメント欄。
エキサイトブログのRSSの設定を「全文表示」にしないといけないとか。

さっそくクライアントさんにお願いして、設定を変えてみたけど、当初うまくいかず・・・
万事休す!と思って、最後の頼みでキャッシュを空にして再読み込みしたら、うまくいきました〜〜〜!

ありがとう、上記サイトの運営の方(涙)

久しぶりにプログラムグルグル地獄に陥りそうだったけど、なんとか脱出しました!

 

スクリーンショット-2016-08-17-10.16.23

▲top作業メモ|2016年8月17日|

昨日、外付けハードディスクが壊れました。

Macの「Time Machine」というバックアップ機能を持たせているハードディスクなんだけど、

ここ数日「バックアップができませんでした」というメッセージが出てきて、気になってました。

たまたま昨日、時間ができたのでユーティリティーソフトで修復しておこうと、

該当のハードディスクを修復してみたところ「修復できませんでした。いますぐバックアップを取って初期化して下さい」

みたいなメッセージが。

なのに、デスクトップ上にはHDのアイコンは出ず。

このハードディスクを破棄して困ることは??と頭がグルグル。

過去に作った仕事のデータが消えるのはとても痛いけど、最悪作り直せばなんとかなる。

が、旅先で撮った写真や、姪甥の写真がなくなる〜〜!

俄然、焦り出す私。

以下、なんとか救出に動いた流れを、今後のためにメモしておきます。

 

ハードディスクがiMac(Mavericks)で認識されなくなる。

念のためMacBook(Mountain Lion)につないでみて起動。

やはり認識されない。

MacBookでユーティリティーにかける。

3時間ほど時間がかかったあとやはり「修復されませんでした」のメッセージ。

しかし、デスクトップ上にHDのアイコンが!

慌てて別の外付けHDをつなぎ、過去の仕事データ、iPhoto Libraryなど必要なものをコピー。

iMacに別の方の外付けをつなぎ、iPhoto Libraryを本体にコピー。

iPhotoを立ち上げてみると、大部分の写真を認識せず。

iPhoto Libraryの容量を見てみると、本来60GBほどあるはずのデータが7GBほどしかない。

 

ここまでが昨日。

 

過去写真、あきらめるしかないかな〜と思いつつ、壊れたHDには70GBのiPhoto Libraryがあったよな〜と、あきらめきれず、今朝もiBookにつないでみる。

昨日と同じ作業をして、デスクトップにアイコンを表示させる。

やっぱり壊れたHDには大量に写真が入っている模様。

この一部がどうやら破損しているため、途中でコピーを中断している状況らしい。

Macを使ってる方、分かると思うんだけど、ぱっと見、このiPhoto Libraryを分解できないと言うか、

一部の写真だけを取り出すってことができない仕組みになってるんですよ。

で、いろいろ調べて、オリジナルの画像だけを取り出す方法を発見。

 

iPhoto Libraryを選択して右クリック。

その中の「パッケージを表示」を選択。

一覧の中の「Masters」もしくは「Originals」の中に元画像が入ってるっぽい。

私の場合は「Masters」の容量が大きいので、こちらに元画像が入ってるとあたりをつけて開いてみると、あった〜!

で、この「Masters」を丸ごとコピーしようとすると、破損してる画像があるらしく、たびたび止まる。

なので、小分けにして救出してます。

ここで破損してる画像はもうしょうがないよね。

でも、一番返ってほしかったボリビアの写真は返ってきそうです(^-^)

 

追記。

けっこう時間がかかったけど、破損している以外の元データを「Masters」からコピー後、

iMacのiPhotoLibraryの「Masters」を同じ要領で開き、コピーしたものと入れ替えました。

そしたら!

ほぼ全部戻ってきました〜(^ー^)

粘ってよかった!!

▲top作業メモ|2014年8月29日|

1年ほど前の記事で、愚痴のような悪態のようなものを書きましたが・・・

http://wp.me/p2QlTX-3t

また、まったく同じ症状に見舞われました。

何度か自分でがんばってみてもダメで、

「またどうせ『送ってくれ』って言われるんだろうな〜・・・」

なんて思いながらエプソンのサポートに電話。

症状を説明しました。

そしたら今回担当して下さったYさんは、症状を聞いただけで具体的に指示をしてくださって、

あっという間に直りました!

 

どこが悪かったかというと・・・

インクカセットのおさまりが悪かっただけ(^^;)

なんかの拍子にちょっとずれたのか、右にカチッと音がするまで差し込まれてなかったようなのです。

たったそれだけで直りました。

 

前回も絶対同じ理由だったはず!と断言できる。

結果的に修理代はいらなかったとはいえ、鳥取まで送った人件費とガソリン代がもったいない!!

 

サポートって当たり外れあるんだな〜と実感。

Appleはわりと平均的にいいのですが(1回だけ大クレームを入れたことありますが^^;)

というわけで、同じ「EPSON PX-1600F」を使ってる方で、「電源を入れ直して下さい」というエラーメッセージが出たという方、

こんな単純な理由で直るかもしれないので、お試しあれ〜。

▲top作業メモ|2013年12月20日|

実験的にスマホのサイトを作ってみています。

基本的な作り方は普通のホームページと変わらないんだけど、ワイドを縦デザインで320px、横デザインで480pxで作る必要がある。

で、そんな感じでテストで作ってみたんだけど、そのままだとiPhoneで見た時にこんなことに・・・

で、こんなんちゃうねん〜〜!と、いろいろ調べてみたら、ありました(^ー^)

スマホのワイドに合わせるには、headに

<meta name=”viewport” content=”width=device-width” />

を入れたらいいそうです。

そしたらちゃんと思ったように表示されました。

よし。先に進めそうだ(^ー^)

▲top作業メモ|2013年7月23日|

前回の記事でhtmlにはうまくjQueryが入りました。

で、肝心のWPへの導入です。

最初に言っておくと、私のWPサイトの作り方はまずhtmlでかっちり作ってから、そこにPHPを加えていくという、なんともイレギュラーなものなので、WPのみでサイトを作ってる方の参考になるかどうかは分かりません(汗)

 

html編でテストとしてつくったデータから、必要な内容をWP用のデータにコピペしていきました。

まずはhead。

<script type=”text/javascript” src=”js/jquery-1.10.1.min.js“></script>
<script type=”text/javascript” src=”js/jquery.nivo.slider.js”></script>

<script type=”text/javascript”>
$(window).load(function() {
$(‘#slider’).nivoSlider(); });
</script>

をWP用のheader.phpにコピペ。

 

つぎにhtml。

任意の場所に

<div id=”slider” class=”nivoSlider”>
<img src=”画像パス” alt=”” title=”” />
<img src=”画像パス” alt=”” />
<img src=”画像パス” alt=”” title=”” />
<img src=”画像パス” alt=”” title=”” />
</div><!– /#slider –>

をコピペ。

 

ええ、もちろん賢明な方はお気づきでしょうが、これではまったく動きません(^^;)

超初心者の私がよくやっちゃうんですが、WP用にパスを書かないといけませんね。

なので、それぞれ、以下の書き方になります。

 

<script type=”text/javascript” src=”<?php bloginfo(‘template_url’);?>/js/jquery-1.10.1.min.js”></script>
<script type=”text/javascript” src=”<?php bloginfo(‘template_url’);?>/js/jquery.nivo.slider.js”></script>

<script type=”text/javascript”>
$(window).load(function() {
$(‘#slider’).nivoSlider(); });
</script>

 

<div id=”slider” class=”nivoSlider”>
<img src=”<?php bloginfo(‘template_url’);?>/images/画像名” alt=”" title=”" />
<img src=”<?php bloginfo(‘template_url’);?>/images/画像名” alt=”" />
<img src=”<?php bloginfo(‘template_url’);?>/images/画像名” alt=”" title=”" />
<img src=”<?php bloginfo(‘template_url’);?>/images/画像名” alt=”" title=”" />
</div><!– /#slider –>

 

で、header.php、home.php(その他任意のページ)、style.css、jsフォルダをftpにアップ。

おばかな私は、これで動くかも〜と思ったのですが、そうは問屋が卸さない(古!)。

なんかもう、Webマスターの方の苦笑いが見えそうですが、WPなのでWP用のプラグインを入れないといけないんですね。

ええ〜〜〜、まさかここにきてこれまでの作業が全部無駄!?

とうんざりしたのですが、解決は簡単でした。

 

プラグインの新規追加で「NIVO slider light 」を検索。

インストールして有効化したら、すぐにスライドショーが見れました(^ー^)

ちょっとナビゲーションのデザインとかが変わってましたが、むしろこっちの方がいい感じなので放置。

で、テストしたのがこんな感じ。

http://komorebinomori.net

まだ写真も入ってないし、Winチェックもしてないぐだぐだ状態ですが、とりあえず忘れないうちに作業工程をばば〜〜っと書いてみました。

まあ、こんなのでもWebのお仕事してるってことで、誰かの勇気づけにでもなれば、と恥を忍んで・・・(笑)

 

▲top作業メモ|2013年6月27日|